Current position:  Home > Default > 10.4.11 upgrade 10.5.4 spamassassin error harvest_completed_queries

10.4.11 upgrade 10.5.4 spamassassin error harvest_completed_queries

Time:November 30
Advertisement
Hi, I have upgraded from 10.4.11 server to 10.5.4
My mail server is operational but SA is not working.
Every few minutes the following message is logged
plugin: eval failed: Can't locate object method "harvestcompletedqueries" via package "Mail::SpamAssassin::PerMsgStatus" at /Library/Perl/5.8.8/Mail/SpamAssassin/Plugin/Check.pm line 94, <GEN10> line 10377.
I am probably missing something obvious but it has me stumped
I am using excellent tools from topicdesk.com ( installed per 10.5 instructions)
Thanks
Advertisement
[66114] warn: config: failed to parse line, skipping, in "/etc/mail/spamassassin/local.cf": auto_learn 1
[66114] warn: config: failed to parse line, skipping, in "/etc/mail/spamassassin/local.cf": safe_reporting 0
[66114] warn: config: failed to parse line, skipping, in "/etc/mail/spamassassin/local.cf": usetersereport 0
[66114] warn: config: failed to parse line, skipping, in "/etc/mail/spamassassin/local.cf": subject_tag * Warning: Junk Mail *
[66114] warn: config: failed to parse line, skipping, in "/etc/mail/spamassassin/local.cf": rewrite_subject 0
[66114] warn: config: failed to parse, now a plugin, skipping, in "/etc/mail/spamassassin/local.cf": ok_languages da en fr it ja
[66114] warn: lint: 5 issues detected, please rerun with debug enabled for more information