Current position:  Home > Default > Custom View not visible in Overview page as AB unless "Reset to Default"

Custom View not visible in Overview page as AB unless "Reset to Default"

Time:October 11
Advertisement
Hi Experts,
I am facing a strange issue here.
I enhanced the component TPMOE and created a custom view ZTRADESPENDEXCEPTION in it.
Now i have added this view as assignment block in all 6 configuration available for the overview page.
I have redefined the DETACH_STATIC_OVW_VIEWS and REATTACH_STATIC_OVW_VIEWS.
The issue i am facing is that my view assignment block is not visible to the user unless he/she goes to the personalization of the overview page and hits "Reset to Default". Once this is done, later on users can change there personalizations and everything works fine.
Now i am not sure i can go and tell all end users to go to personalization of the TPMOE overview page and click on "Reset to Default".
Is there any other way i can show my view to the end users?
I have done this on the lines of overview page layout changing when you select product planning basis while creating Trade Promotions.
Thanks and Regards
Gaurav Kumar Raghav
Advertisement
Hi Amar,
My coding is given below.
In DETACH_STATIC_OVW_VIEWS, the coding is:
Call Super Method
ls_viewid-view_id = '<My View Name>'.
Append ls_viewid to rt_view_id
In REATTACH_STATIC_OVW_VIEWS, the coding is:
Call Super Method
if <flag>  = 'X'.
ls_viewid-view_id = '<My View Name>'.
Append ls_viewid to rt_return.
endif.
In debug mode, the coding get executed correctly and my view is returned for attachement.
For each user, the first time, i need to say "Reset to Default".
After that it works fine, my view is displayed.
Is the program "BSP_DLC_DELETE_PERSONALIZATION"  a good solution to my problem?
Thanks and Regards
Gaurav Kumar Raghav