Current position:  Home > Default > Keywords in topic-based index not displaying in application tab

Keywords in topic-based index not displaying in application tab

Time:October 11
Advertisement
We have a large binary index built from topic-based keywords.
The project itself is fairly substantial (2800+ topics), and the
.chm file produced works fine, index and all. However, only a small
fraction of the keywords display on the index tab of the RH
application.
Editing the rhakeyword.apj file doesn't seem to have any
effect. Right now, for example, the file in use is totally empty,
but the same subset of topics is displaying in RH.
Advertisement
Monday morning update: Friday afternoon the reimporting of
topics seemed to be rebuilding the index. This morning, upon
reopening the project and resuming the process, the topics I was
importing stopped registering on the index tab. Attempting to add
them manually, though, resulted in the "topic already exists"
message.
Further testing: I added several hundred topics Friday,
nothing shows in the rhkkeyword.apj file. All of a sudden today RH
is adding index entries there.
This is getting silly.

How to apply conditional build tags to the topic title that is displayed in Search tab of CHM?

-0001-11-30

I have the project in which 2 different words are used to reffer to one objects (this word/term depends on the customer). All other information related to functionality, steps, etc. are common. So: In the help content (body of the files), I created 2

Query Transformation in Function Based Index's Expression

-0001-11-30

Hi All, I am having a wired issue with Function Based Indexes on Orcale 10.2.0.3 running on Solaris 5.9. I have created two FBI on two tables using following syntax. CREATE INDEX EQHUB.IDX_BBO_WRT_DES_FBI ON EQHUB.BBO_WARRANT_PRICING (CASE WHEN lates

Impdp not importing function based index correctly.

-0001-11-30

We noticed that a process running in our develop database was running much faster than in the production database. After investigating we found that on the development database the process was using an index on the main large table and on the product

Function based indexes on object tables

-0001-11-30

Hi, I am trying to create a function based index on an object table. I am getting the following error: SQL> create index cell1_indx on cell1(create_cell1(id)) indextype is mdsys.spatial_index; create index cell1_indx on cell1(create_cell1(id)) indext

Function based indexes doing full table scan

-0001-11-30

Guys, I am testing function based indexes and whatever I do it is doing a full table scan. 1)I have set the following init parameters as QUERY_REWRITE_ENABLED=TRUE QUERY_REWRITE_INTEGRITY=TRUSTED 2)CREATE INDEX i3 ON emp(UPPER(ename)); 3) ANALYZE TAB

How to define error message for function based index violation?

-0001-11-30

Hi, I am generating Forms 6i from Designer 6i. I have a function based index to enforce case insensitive name uniqueness. With check constraints I can specify constraint violation error messages that will be displayed in Forms at runtime if needed. H

RH7 doesn't break Word document into topics based on headings

-0001-11-30

Hi, Have been working with RH7 and Word 2007 for some time and everything was OK. Yesterday tried to generate another Help by importing a Word document. RH just didn't generate topics based on the headings. The entire document was imported into a sin

Function-based index with OR in the wher-clause

2015-10-11

We have some problems with functin-based indexes and the or-condition in a where-clause. --We use Oracle 8i (8.1.7) create table TPERSON(ID number(10),NAME varchar2(20),...); create index I_NORMAL_TPERSON_NAME on TPERSON(NAME); create index I_FUNCTIO

Creation of function based index using escape

2015-10-11

Hello, I have the following SQL, sometimes performing bad: SELECT DISTINCT UPPER(A.PROCESSIDCODE), UPPER(A.RULENAME), CHARSET FROM XIB_DETECT A, XIB_PROCESSIDPROPERTIES B, XIB_RULES C WHERE ( A.KEY1 = :P1 OR ( :P1 like REPLACE(REPLACE(REPLACE(REPLACE

Function-Based Indexes for 8.1.6 SE and 9iAS

2015-10-11

I have installed the 9iAS Portal into a 8.1.6 SE database, and I cannot get the Function-Based Index feature to turn on. I have set QUERY_REWRITE_INTEGRITY=trusted, QUERY_REWRITE_ENABLED=true and COMPATIBLE="8.1.0.0.0". The feature will still no

FUNCTION-BASED INDEX ( ORACLE 8I NEW FEATURE )

2015-10-11

제품 : ORACLE SERVER 작성날짜 : 2004-08-16 FUNCTION-BASED INDEX ( ORACLE 8I NEW FEATURE ) ============================================== SCOPE 10g Standard Edition(10.1.0) 이상 부터 Function-based Index 기능이 지원된다. Explanation 1. 개요      Function-based index는, 함

Query not considering function based index in oracle 11g

2015-10-11

I have a query which used Function Based Index when run in oracle 9i but when I run the same query without any changes, it does not consider index. Below is the query: SELECT distinct patient_role.domain_key, patient_role.patient_role_key, patient_ro

Function-based indexes

2015-10-11

Oracle documentation on "How Function-Based Indexes Work" states that for the creation of a function-based index in the user's own schema, the user must be granted the QUERY REWRITE system privileges. And MUST have the following initialization p

Function-based Index and an OR-condition in the WHERE-clause

2015-10-11

We have some problems with functin-based indexes and the or-condition in a where-clause. (We use oracle 8i (8.1.7)) create table TPERSON(ID number(10),NAME varchar2(20),...); create index I_NORMAL_TPERSON_NAME on TPERSON(NAME); create index I_FUNCTIO

Unable to create function based Index

2015-10-11

Hi All, I created a function as below: create or replace function eqx_oklb_term_date_nvl(pin_term_date date) return date deterministic is l_sub_date date := sysdate+1; l_return_value date := l_sub_date; begin l_return_value := nvl(pin_term_date, l_su

Index not displayed in Navigator (Version 1.5.4)

-0001-11-30

Hi, I have few indexes in a schema which were created by Sql Tuning Advisor; hence their names are system generated (in dba_indexes, generated = 'Y' for indexes not displayed). Accordingly to 364055.1 this seems to be an expected behavior (at least f

Function Based Index on Date Column

-0001-11-30

Hi All, I need to execute a query like this : SELECT * FROM ORDERS WHERE APPROVE_DATE IS NULL I read anywhere that this will cause unnecessary FTS so that I should create function based index. I have tried one below , but not sure that this is correc

Function Based index getting disabled frequently

-0001-11-30

I am facing some error like "ORA-30554: function-based index ORADB1.FUN_INDX1 is disabled" in the development database. I verified that the function which is referred by the index is valid. Once I even got the tedious generic error ORA-600 becau

Function Based Index MOD(column_name,8)

-0001-11-30

For a function based index (MOD(column_name,8), the query is not using it. Do anyone have a solution to it? The table is having millions of rows.Oracle only uses indexes if the number of returned rows is less than (i think) 4%. In your case the numbe