Current position:  Home > Default > T430s Doesn't Turn on - Lights Flash Once

T430s Doesn't Turn on - Lights Flash Once

Time:December 10
Advertisement
Hi,
I'm trying to fix a friend's T430s and the issue is that it doesn't turn on. With the battery plugged in, nothing happens. No lights and no sounds. When I plug the adapter in the buttons along the top of the keyboard (volume mute,power, etc.) and then they turn off and nothing. The motherboard was replaced, but the issue remains. 
Any tips or trick are much appreciated
Thanks
Advertisement
Hi Cimanim,
Welcome to Lenovo Community!
As per the query we understood that you are facing issue with No POST on your ThinkPad T430s.
Have you checked with performing power drain by removing the power adapter and battery from the system, hold the power button for 15 to 20 seconds do this process for 2 to 3 times and connect only power adapter and check.
If you find the issue still persists, then I suggest you to contacts Lenovo technical support if the system is under warranty or approach any nearby service center.
Please click here to contact Lenovo customer support for your region to get the detail of service centers.
Hope this helps.
Best regards,
Hemanth Kumar
Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.
Follow @LenovoForums on Twitter!