Current position:  Home > Default > Unable to start em after deploying SOA composites

Unable to start em after deploying SOA composites

Time:November 30
Advertisement
Hi
I have installed SOA 11.1.1.1.3 and cretaed the repositories. I have created a new domain soa_domain which supports SOA,Enterprise Manager,BAM.
The first time I started the server, it started successfully and I was able to deploy two SOA composites and also test them successfully through the em console.
Today I restarted my admin server and I find the following logs during startup:
####<Jan 6, 2011 10:07:47 AM GMT+05:30> <Warning> <J2EE> <INMUCHPC00278> <AdminServer> <[ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<anonymous>> <> <> <1294288667512> <BEA-160195> <The application version lifecycle event listener oracle.security.jps.wls.listeners.JpsAppVersionLifecycleListener is ignored because the application em is not versioned.>
####<Jan 6, 2011 10:07:58 AM GMT+05:30> <Warning> <HTTP> <INMUCHPC00278> <AdminServer> <[ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1294288678205> <BEA-101162> <User defined listener com.sun.faces.config.ConfigureListener failed: java.lang.NoSuchMethodError: org.apache.xerces.impl.xs.XMLSchemaLoader.loadGrammar([Lorg/apache/xerces/xni/parser/XMLInputSource;)V.
####<Jan 6, 2011 10:07:58 AM GMT+05:30> <Error> <Deployer> <INMUCHPC00278> <AdminServer> <[ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1294288678441> <BEA-149231> <*Unable to set the activation state to true for the application 'em'.*
weblogic.application.ModuleException:      at weblogic.servlet.internal.WebAppModule.startContexts(WebAppModule.java:1514)
     at weblogic.servlet.internal.WebAppModule.start(WebAppModule.java:486)
     at weblogic.application.internal.flow.ModuleStateDriver$3.next(ModuleStateDriver.java:425)
     at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:41)
     at weblogic.application.internal.flow.ModuleStateDriver.start(ModuleStateDriver.java:119)
     at weblogic.application.internal.flow.ScopedModuleDriver.start(ScopedModuleDriver.java:200)
     at weblogic.application.internal.flow.ModuleListenerInvoker.start(ModuleListenerInvoker.java:247)
     at weblogic.application.internal.flow.ModuleStateDriver$3.next(ModuleStateDriver.java:425)
     at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:41)
     at weblogic.application.internal.flow.ModuleStateDriver.start(ModuleStateDriver.java:119)
     at weblogic.application.internal.flow.StartModulesFlow.activate(StartModulesFlow.java:27)
     at weblogic.application.internal.BaseDeployment$2.next(BaseDeployment.java:1267)
     at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:41)
     at weblogic.application.internal.BaseDeployment.activate(BaseDeployment.java:409)
     at weblogic.application.internal.EarDeployment.activate(EarDeployment.java:58)
     at weblogic.application.internal.DeploymentStateChecker.activate(DeploymentStateChecker.java:161)
     at weblogic.deploy.internal.targetserver.AppContainerInvoker.activate(AppContainerInvoker.java:79)
     at weblogic.deploy.internal.targetserver.BasicDeployment.activate(BasicDeployment.java:184)
     at weblogic.deploy.internal.targetserver.BasicDeployment.activateFromServerLifecycle(BasicDeployment.java:361)
     at weblogic.management.deploy.internal.DeploymentAdapter$1.doActivate(DeploymentAdapter.java:51)
     at weblogic.management.deploy.internal.DeploymentAdapter.activate(DeploymentAdapter.java:200)
     at weblogic.management.deploy.internal.AppTransition$2.transitionApp(AppTransition.java:30)
     at weblogic.management.deploy.internal.ConfiguredDeployments.transitionApps(ConfiguredDeployments.java:240)
     at weblogic.management.deploy.internal.ConfiguredDeployments.activate(ConfiguredDeployments.java:169)
     at weblogic.management.deploy.internal.ConfiguredDeployments.deploy(ConfiguredDeployments.java:123)
     at weblogic.management.deploy.internal.DeploymentServerService.resume(DeploymentServerService.java:180)
     at weblogic.management.deploy.internal.DeploymentServerService.start(DeploymentServerService.java:96)
     at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
     at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
     at weblogic.work.ExecuteThread.run(ExecuteThread.java:173)
*Caused By: java.lang.NoSuchMethodError: org.apache.xerces.impl.xs.XMLSchemaLoader.loadGrammar([Lorg/apache/xerces/xni/parser/XMLInputSource;)V*
     at org.apache.xerces.jaxp.validation.XMLSchemaFactory.newSchema(Unknown Source)
     at javax.xml.validation.SchemaFactory.newSchema(SchemaFactory.java:594)
     at com.sun.faces.config.DbfFactory.initSchema(DbfFactory.java:151)
     at com.sun.faces.config.DbfFactory.<clinit>(DbfFactory.java:120)
     at com.sun.faces.config.ConfigManager$ParseTask.<init>(ConfigManager.java:372)
     at com.sun.faces.config.ConfigManager.getConfigDocuments(ConfigManager.java:280)
     at com.sun.faces.config.ConfigManager.initialize(ConfigManager.java:202)
     at com.sun.faces.config.ConfigureListener.contextInitialized(ConfigureListener.java:195)
     at weblogic.servlet.internal.EventsManager$FireContextListenerAction.run(EventsManager.java:481)
     at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
     at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
     at weblogic.servlet.internal.EventsManager.notifyContextCreatedEvent(EventsManager.java:181)
     at weblogic.servlet.internal.WebAppServletContext.preloadResources(WebAppServletContext.java:1863)
     at weblogic.servlet.internal.WebAppServletContext.start(WebAppServletContext.java:3126)
     at weblogic.servlet.internal.WebAppModule.startContexts(WebAppModule.java:1512)
     at weblogic.servlet.internal.WebAppModule.start(WebAppModule.java:486)
     at weblogic.application.internal.flow.ModuleStateDriver$3.next(ModuleStateDriver.java:425)
     at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:41)
     at weblogic.application.internal.flow.ModuleStateDriver.start(ModuleStateDriver.java:119)
     at weblogic.application.internal.flow.ScopedModuleDriver.start(ScopedModuleDriver.java:200)
     at weblogic.application.internal.flow.ModuleListenerInvoker.start(ModuleListenerInvoker.java:247)
     at weblogic.application.internal.flow.ModuleStateDriver$3.next(ModuleStateDriver.java:425)
     at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:41)
     at weblogic.application.internal.flow.ModuleStateDriver.start(ModuleStateDriver.java:119)
     at weblogic.application.internal.flow.StartModulesFlow.activate(StartModulesFlow.java:27)
     at weblogic.application.internal.BaseDeployment$2.next(BaseDeployment.java:1267)
     at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:41)
     at weblogic.application.internal.BaseDeployment.activate(BaseDeployment.java:409)
     at weblogic.application.internal.EarDeployment.activate(EarDeployment.java:58)
     at weblogic.application.internal.DeploymentStateChecker.activate(DeploymentStateChecker.java:161)
     at weblogic.deploy.internal.targetserver.AppContainerInvoker.activate(AppContainerInvoker.java:79)
     at weblogic.deploy.internal.targetserver.BasicDeployment.activate(BasicDeployment.java:184)
     at weblogic.deploy.internal.targetserver.BasicDeployment.activateFromServerLifecycle(BasicDeployment.java:361)
     at weblogic.management.deploy.internal.DeploymentAdapter$1.doActivate(DeploymentAdapter.java:51)
     at weblogic.management.deploy.internal.DeploymentAdapter.activate(DeploymentAdapter.java:200)
     at weblogic.management.deploy.internal.AppTransition$2.transitionApp(AppTransition.java:30)
     at weblogic.management.deploy.internal.ConfiguredDeployments.transitionApps(ConfiguredDeployments.java:240)
     at weblogic.management.deploy.internal.ConfiguredDeployments.activate(ConfiguredDeployments.java:169)
     at weblogic.management.deploy.internal.ConfiguredDeployments.deploy(ConfiguredDeployments.java:123)
     at weblogic.management.deploy.internal.DeploymentServerService.resume(DeploymentServerService.java:180)
     at weblogic.management.deploy.internal.DeploymentServerService.start(DeploymentServerService.java:96)
     at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
     at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
     at weblogic.work.ExecuteThread.run(ExecuteThread.java:173)
And when I check the Admin console,Deployments section, the em application status is shown as failed. I tried starting it up from the Admin Console as well.
But no luck....
Has some one come across this before? Could you please help me figuring out the cause of this problem and how to overcome this?
Regards
Kshama
Advertisement
When I mentioned I have deployed DBAdapter and JMSAdapter, I meant that, I added new outbound connection pools to the configuration and redeployed the adapters.
Also, I compared the Admin Server logs( before and after redeploying Adapters), I found that there was a difference in java classpath it was referring to.
After deployment of adapters, when I restarted the server, the classpath was referring to my classpath environment variable also which had an entry pointing to ant-1.6/xercesImpl.jar.
I removed the entry from environment variable classpath.
I have now reverted back the deployment order as before and everything seems to be working fine.
Thanks All for your instant replies.
Regards
Kshama
Edited by: Kshama Tamhankar on Jan 6, 2011 9:36 PM

Error while deploying SOA composite via ant

2015-10-11

I am getting following error while deploying SOA composite through ant from SOA server (UNIX).It is unable to get mds configuration. Jdeveloper is not installed in SOA server. I am trying to copy the SOA project from local machine to SOA server and t

Cannot deploy SOA composite to a managed server

2015-10-11

My problem: cannot deploy SOA composite to a managed server. The following is what I did: 1. I created a domain "devDomain". admin server is created automatically for me. *2. I created a manged server (soa_server1) on my domain after.* 2. starte

Error While Deploying SOA composite 11g

2015-10-11

Hi All, i am getting the following error while deploying a soa composite. I dont have any JAVA embedding in my code.Also I tried with a simple hello world bpel even its throwing the same error.My soa version version is 11.1.1.3 Kindy help me. Deployi

Error while deploying SOA composite

2015-10-11

Hi, I am getting the below error while deploying the SOA composite. Error(45,34): Failed to compile bpel generated classes. failure to compile the generated BPEL classes for BPEL process "ApprovalProcess" of composite "default/ResourceSeria

Error during deploying SOA Composite

2015-10-11

I have created a SOA Composite in which I am trying to access an External Web Service. The compilation goes fine but its failing at the time of deployment to Soa Server. My BPEL consists of following activities-> RecieveInput-> Assign -> Invoke -

Error in deploying SOA composite using ant

2015-10-11

Hi, When I try to deploy a SOA composite using ant utility, I am getting error as follows: C:\JDeveloper11\MiddlewareHome\jdeveloper\bin>ant -f ant-sca-deploy.xml -Dserver URL=http://gdiora001.in.ibm.com:7001 -DsarLocation=C:\po\POProcessing\POProces

Deploying soa composite error

-0001-11-30

Hi, I am trying to deploy a soa composite from EM it gives me the following error. Please let me know the fix for this issue. Deploying on partition "Bhavani" of "/Farm_edsoastg/edsoastg/soa_cluster1" ... Deploying on "/Farm_edsoa

OIM11gR2PS1 - Invalid task definition Error when deploying soa composite

2015-10-11

Hi, I am having a issue modifying the approval policies. I cant select the composite for approval workflow. I can see the composite as "Active" in soa-infra and it is shown in the search box when selecting the composite to be used in approval po

Deploying SOA composite from Jdeveloper: 11g

-0001-11-30

When I try to deploy a modified SOA project from JDeveloper, it is trying to connect to the soa_server1 using SSL. Since SSL is not configured in my test environment, I get an error saying Connection refused. Is there a setting I can change so JDevel

Control deployed SOA Composite from another BPEL

-0001-11-30

Hi All, I am trying to control the bpel process(activate/retire) on the server, by using JAVA Embedding activity in another bpel. So i am using the below code. import java.util.Hashtable; import java.util.*; import javax.naming.Context; import oracle

SOA Composite (having refernce to MDS )Deployment thru ANT script

2015-10-11

I have been trying to deploy SOA composite which has reference to 'oramds:/soa/shared/workflow/TaskServiceInterface.wsdl' thru ANT script.But getting below error - scac-validate: [echo] Running scac-validate in D:\apps\saurabhk\deployment\Error Loggi

Is it possible to directly deploy SOA service .jar on the Oracle Java Cloud?

-0001-11-30

I tried to deploy the SOA composite SAR File(.jar) to JCS console but got following error:- Starting action "Deploy Application" Deploy Application started Invalid archive provided: not a deployable EAR or WAR file. Archive may be poorly formatt

Unable to deploy the SOA composite through the EM

-0001-11-30

Hi, I have created SOA Composite project (version 11.1.1.1.0). This is a simple project which takes message from one JMS queue and puts in another JMS queue. Now I wanted to deploy this in another instance of the SOA Suite( version 11.1.1.3.0). When

Error message deploying a composite in SOA Suite 11g

2015-10-11

Hello, We are attempting to deploy a composite to SOA Suite 11g (11.1.1.3). We're getting an 'Unable to register service' error message. When I inspect the log files I see the following entry as the first error: Failed to retrieve policy[[ oracle.wsm

SCAC-50012 error while deploying a SOA composite

2015-10-11

I created a SOA compsoite using the guide at http://download.oracle.com/docs/cd/E14571_01/doc.1111/e14309/soa_api.htm but when I try to deploy the composite I'm getting SCAC-50012 error. I'm using JDeveloper 11.1.1.5 Following is the error I'm seeing

Error deploy SOA application "Deployment Failed: Unable to register service

-0001-11-30

Hi All I have build a SOA application and tried to build and deploy to my SOA server but stuck with below error msg. Step-1: Created the application, with BPEL components etc. Step-2: Right click on the application, then Deploy -> To -> My Server..

How do you use a SOA Composite after you have deployed it and tested it?

2015-10-11

I have created a SOA Composite application, deployed it with no problems, and tested and it works. However I am having trouble finding info on what to do next. I really would like to know how to use this SOA Composite application in a web application

Urgent Help Needed : Error While deploying the composite to soa server

2015-10-11

Hi , I an facing an issue in the deployment of the composite: The error says that: [12:50:56 PM] Error deploying archive sca_Project8_rev1.0.jar to partition "default" on server soa_server1 [http://ocmappsvr.outrigger.lan:8001] [12:50:56 PM] HTT

Error while deploying/Undeploying the SOA composite

2015-10-11

Hi All, I am a new bie to OIM 11g. I have created a simple batch file with the commands for deploying/Undeploying/Disbaling/Enabling the SOA composites. I am trying to deploy/Undeploy/Disbale/Enable the SOA composites using the batch file. Following